m-chrzan.xyz
aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d41e17..0ce6168 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 3.5)
project(brandes CXX)
+find_package ( Threads REQUIRED )
+
option(DEBUG OFF)
if (DEBUG)
@@ -18,3 +20,4 @@ set(SOURCE_FILES src/brandes.cc
src/graph.h)
add_executable(brandes ${SOURCE_FILES})
+target_link_libraries(brandes ${CMAKE_THREAD_LIBS_INIT} )